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CHAPTER -5

ADVANCED FEATURES OF MICROSOFT WORD
OBJECTIVES OF THIS LESSON

In addition to the basic features described in the previous chapter, MS-Word also provides very useful
additional features such as Import, Export, Frame, Table, Mail-merge, Macros etc. These advanced
features are discussed in this chapter. Readers will be able to understand and used the following
advanced features of MS-Word:
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Import and Export
Working with Frames
Multi column specification of a document
Various ways to insert the pictures in Word document
Creating and formatting of table
Macro and its uses
Mail Merge
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Importing, Exporting and Inserting Pictures
5.2.1 Importing Clip Art Images

5.2.2 Importing Graphics from Other Files
5.2.3 Export Data from Ms Word

Working with Frames
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5.4.1 Creating Multi-Column Documents
Picture

5.5.1 Inserting a Picture Using Clip-Art
5.5.2 Inserting a Picture From File

5.5.3 Inserting a Picture from Scanner or Camera
5.5.4 Drawing Objects in a Document

5.5.5 Inserting Autoshapes

5.5.6 Inserting a Picture Using Word Art
5.5.7 Inserting a Chart

Create a Table

5.6.1 Inserting Row and Column in Existing Table
5.6.2 Delete a Table

5.6.3 Delete Row or Column

5.6.4 Change the Column Width in a Table
5.6.5 Change the Row Height in a Table
5.6.6 Autofit

5.6.7 Sorting Text in Table
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5.6.8 Formatting Text in Table
5.6.9 Formatting of Table
5.7 Macros
5.7.1 Recording a Macro
5.7.2 Running a Macro
5.8 Mail Merge
5.9 Shortcut Keys
Summary of the Lesson
Self Assessment Questions and Exercises
5.1 INTRODUCTION

MS-Word is a powerful word-processing tool. Apart from common features, MS-Word also provides
very useful advanced features such as Import, Export, Frame, Table, Mail-Merge, Macros etc. These
advanced features are quite helpful and are discussed in this chapter.

5.2 IMPORTING, EXPORTING AND INSERTING PICTURES

MS-Word can directly import graphics file created in most of the common graphics file formats. For
example if you create a drawing in Paint, AutoCAD or CorelDraw and want to show it in your word
document, you can insert it very easily. Some of the common graphics file formats that MS-Word can
use are given as:

1. Windows Metafile ((WMF)

2. Enhance Metafile (.EMF)

3. JPEG File Interchange Format (.JPG)
4. Kodak Photo CD (.PCD)

5. PC Paintbrush (.PCX)

6. Windows Bitmap (.BMP) etc.

Graphics can be imported either from other applications by using picture objects command from
insert menu or copy a graphics from other file and paste in document.

5.2.1 Importing Clip Art Images

Word includes a number of Clip Art images that you can include in your document. For instance, it
has Clip Art files for an anchor, dinner, animals, office equipment etc. To insert any graphics file in
your document, use the insert, picture command

To insert the clip art at any desired position of the text follow the following steps:
1. Position the insertion point where you want to insert the graphics

2. From insert menu choose picture and then choose clip art

3. A dialog box will appear on your screen from which you can select image.

4. Select the image that you want to import in your document.
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5. Click at OK button.
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5.2.2 Importing Graphics from other files

If you import an image or graphics into a MS-Word document, MS-Word inserts or embedded, the
image in MS-Word document and the image becomes a part of the document. To import a graphics
object or any part of the graphics object or a saved file containing graphics matter, copy the graphics
to the clipboard using copy from the edit menu and then paste into the current document or following
steps are used:

1. In your MS-Word document, on the Insert Menu, click Picture > From File

2. Browse to the location of the image file you want to insert in your MS-Word source document, and
then select the image file.

3. Click the insert button. MS-Word inserts the image in your document and displays the image.
5.2.3 Export Data from MS Word

Exporting Data from MS Word document can provide data for other applications, such as Microsoft
Excel, to analyze. To share this data with another application you can export it in a format the other
application recognizes. You also need to organize the data in a consistent pattern the receiving
application expects. The most basic format that other applications accept is plain text; word can save
any document in this format. Organizing the data in a pattern requires checking that the file contains
consistent markers to indicate where data records and their fields start and end.

Steps to export data from MS Word
1. Open your MS-Word application and the word document that contains the data you want to export.

2. Check the data for proper organization. Each data record must start on a new line and contains
separators. Such as comma, space or tab between each field of information.

3. Click the file tab and select the Save As command.
4. Choose the format from “save as type” drop down menu in Save As dialog box.
5. Enter a name for your data export file.

6. Click the save button to export the data.
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5.3 WORKING WITH FRAMES

A frame is created with the help of text tool or with picture frame button. Frames are used for text or
provide a specified area for a particular thing. We can edit text by placing a cursor in the frame and
for editing text we can highlight the text.

Steps for placing a frame in document:

. Firstly select text area option and drop down with the help of cursor.
Select Format = frame menu.

. In frames, two options are present first is, ‘table of content in frame’ and ‘new frame
page. Select ‘new frame page’ as shown.

2} Document3 - Microsoft Word _
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5.4 COLUMNS

Displaying information in columns gives the writer more options for displaying different types of
information on a page while remaining easy for the viewer to read. Certain kinds of information are
best displayed using columns. Newspaper, newsletters, reports, announcements, school projects, or
other types of publications, often use Word's column feature.
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5.4.1 Creating Multi-Column Documents

Advanced Features of Microsoft Word

In MS-Word, multi-column documents can be created by two ways:

By using column option under format menu.
By using word’s table function.

Creating Columns using column option

To make columns in a document, click on format menu = columns. From the dialog box select the
number of columns their width, spacing etc.
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Creating Columns using Table Function

A table is made up of rows and columns. The intersection of rows and column is called a cell. Cell is
used to enter text. A table is generally used to organize data and information in a better way. For

making multi column document, we can make table and nested tables.

5.5 Picture

In MS-Word, mainly two types of graphics are used. These are drawing objects and pictures. Drawing
objects include Autoshapes, curves, lines, and WordArt etc. Pictures are graphics that are created
from another file. Pictures include bitmaps, photographs, scanned pictures and clip art etc.
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5.5.1 Inserting a Picture Using Clip-Art
MS -Word provides many options to insert a picture and _

for this we can use clip art, we can insert a picture from

file, scanner or camera, in our document. The picture

Twpe a gquestion For help

option shows drawing option and word art option. The

new picture could be in the form of charts. We can also
use clip art in ms-excel and power point also.

Steps to insert clip art:-

1. Click on insert menu > picture—> clip art.

2. Select an image from clip art.

3. A dialog box will appear on screen from which image

can be searched.

4. Select the image that you want to insert in your

document.

5.5.2 Inserting a Picture from File

Steps to insert a picture from file:

Click on Insert menu-> picture - From File.
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Remarks -A dialog box will appear that will ask for name and location for picture to be inserted.
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-Give picture name and location to insert the picture.
5.5.3 Inserting a Picture from Scanner or Camera
- On the Insert menu in Microsoft word, click on picture, and then click on From Scanner
or Camera.
-If camera is selected, a picture needs to be clicked first, then it will be inserted.
-If scanner is chosen, firstly we have to set image settings. Then image will be displayed
on screen.
5.5.4 Drawing Objects in a Document

For drawing graphics objects in a word document, we can use drawing toolbar. While clicking on
Insert menu, then picture, then new drawing, A drawing canvas will appear on word document. By
using drawing toolbar, we can draw any kind of picture.
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5.5.5 Inserting Autoshapes

We can insert pre-defined shapes in our word document.
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Click on insert menu—> picture—> autoshapes.
A AutoShapes toolbar will appear.

Choose the desired shape from that and draw it.

AutoShapes

&J'E?%Eu%ﬁblﬁ

5.5.6 Inserting a Picture Using Word Art

Click on insert menu—> picture—> word art.

A dialog box will appear.
B
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Choose a word art style, press ok.

Type the text in next dialog box and press ok.

)
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Size:
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For editing the word art object, either double click on object or choose word art toolbar from
view menu->toolbars—>WordArt.
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5.5.7 Inserting a Chart

It is a feature in MS Word which enables the user to see chart in document.
In main menu we can select insert > picture > chart to see any chart in a document.
Chart is used in different word documents mainly in business documents which has numerical values.

Chart enables the correct and better view of numerical values.

As we choose chart option, a chart is appeared with datasheet in document. Modify the data sheet as
per requirements and click outside the chart and datasheet. The chart will appear in document.
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5.6 CREATE A TABLE

Creating table in MS Word is a very powerful and flexible facility. Table help you to emphasize and
organize information in a document. A table consists of rows and columns of boxes called cell, that
you can fill with text or graphics. Steps for creating a table

e Click on the Table menu.

T4 Document1 - Microsoft Word
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e A drop down menu appears. NEHE RO G Y E
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e Click OK.
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5.6.1 Inserting Row and Column in Existing Table
To insert rows and column in existing table, steps are following:
e Place the cursor in table, where row is to be inserted.
e Click on table menu option.
e Click on insert. A submenu will appear.
e Click on Rows above or Rows below depending on choice.
In the same way, column can be inserted also.
L-§|1¢12 1 3 1B o o l 3 I X
& New row added above
b c d E
z h i i
1 m n Q
5.6.2 Delete a Table

e  C(Click the table.

e Pointing to Delete on the Table menu, click Table.
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5.6.3 Delete Row or Column
0. Take the mouse pointer in the row or column that you want to delete.
1. Click the Table menu option.
2. A submenu will appear as soon as, you click on Delete.
3. Click on the option Rows or Column, depending on your requirement.

5.6.4 Change the Column Width in a Table

e Place the pointer on the column boundary you want to do wide until it becomes and then drag
the boundary until your column gets the desired width.

e If you want to change the column width to a specific measurement, click a cell in the column,
on the Table menu, click Table Properties and then click the Column tab.

e Select the options you want.

i Table Window Help
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5.6.5 Change the Row Height in a Table

e Place the pointer on the row boundary you want to move until it becomes and then
drag the boundary.

e If you want to change a row height to a specific measurement, click a cell in the
row, on the Table menu, click Table Properties, and then click the Row tab.

e Select the options you want.

Table Properties

Tahle Rowy lCDIgmnl Cell ]

W Specify height: -

lem =3 Rowheightis: |At least
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r

% Previous Row Mext Row ¥

Ok | Cancel |

5.6.6 Autofit

Auto fit is a great feature in word. This feature automatically tries to adjust text in cells so as to keep
consistent look of the data in table. For using autofit, perform following steps:

e (Click on Table menu.

e Select Auto fit. A submenu will appear.
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e Select one of the following:-

1.

4.
5.

Auto fit to contents: Automatically adjust the width of columns in the
table.

Auto fit to Window: Automatically resizes the table to make it fit into
window.

Fixed column width: This option will make width of all columns same as
current column width.

Distribute rows evenly: This will make all rows of same height.

Distribute columns evenly: This will make all columns of same height.

5.6.7 Sorting Text in Table

Microsoft word allows us to sort data in a table. For sorting ascending and descending are the two
options. It is also possible to sort data from two or more columns. To perform sorting, steps are:

e Select column which we want to sort.

e Click on table menu->select sort option.

o A dialog box will appear.
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Sort (555
Sort by 4
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Column 1 Type: =
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[ Options. .. ] oK [ Cancel l

e Specify column name, its type and sort order. Press ok.

5.6.8 Formatting Text in Table

Once a table is created, we can easily enter text in the table. The table data could require formatting.

The formatting can be done on individual cells of the table or whole table data can be formatted in
one time.

e Click on cell or select table to format.
e Apply formatting as normal text using formatting toolbar.

5.6.9 Formatting of Table

Like table text, the whole table can be formatted also. We can add and remove borders; change the
border type, border colors, and cell fill color. The text of table can be formatted like normal text. We
can also change the direction of text in table cells.

There are two ways to format a table:
e Click on table menu—> choose Table AutoFormat.

e A dialog box will appear. Choose required formatting.
Table AutoFormat @

Category:
[ibesyles 1
Table styles:

Table Classic 4 Al
Table Colorful 1 —

Table Colorful 2
Table Colorful 3 = Relele o
Table Columns 1
Table Columns 2
Table Columns 3
Table Columns 4
Table Columns 5

Modify..
Table Contemparary Mediy
Table Elegant
T — - | Osfet
Preview
Jan Feb Mar Toral
East 7 7 5 19
West 6 4 7 17
South 8 7 9 24
Tortal 21 18 21 60
Apply spedal formats to
|¥] Heading rows V] Last row
| First column V| Last column

[ aoy | [ concel

Remarks

97



Advanced Features of Microsoft Word
5.7 MACROS
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As a document is created in MS- Word, it is find that we must complete many small tasks over &
over. If a task is performed repeatedly in Microsoft Word, then the task can be automated by using a
macro. Basically, a macro is a series of word commands and instructions that is used as group
together as a single command. Word macros can help save time by automating repetitive tasks such
as:

Inserting frequently-used phrases
*Formatting headers and footers
*Inserting page and column breaks

After recording a macro containing all of the steps that make up a task, we can direct Word to
automatically perform this task at any time by running that macro,

5.7.1 Recording a Macro
e Open the document.

e From the Tools menu, select the Macro submenu. Click on Record New Macro

Tooks | Table Window Help Fouit Reader PDF

T spelingand Grammar... F7 | @} _g,g &l 0% - &
il Research... Alt+-Click
Language »

TR TR X
ord o |
Speech
Letters and Maiings »

Macro P ¥ | Macros... Al4+FE
Customize... @ Record New Macro...

£ | visual Basic Editor Alt+F11

@8 Microsoft Script Editor  Alt+Shift4F11

A dialog box will appear.

Macro name:

Assign macro to

g :\ Toolbars Keyboard

Store macro in:
All Docurnents (Marmal, dak ) w

Description:
Macro recorded 5/5/2015 by KAPIL

[ CK ] [ Cancel
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Provide required information. Press ok. We can assign a keyboard shortcut to macro. Recording will
get started. The Stop Recording toolbar will appear in the upper left of Word window.

Perform the tasks to be repeated. And stop recording.
5.7.2 Running a Macro
o  Press the keystroke combination that you assigned when recorded the macro,
e  From the Tools menu, select the Macro submenu. Click on Macros.

e (Choose macro name to run.

Macros ===

Macrosin: | All active templates and documents E

Description:
Macro created 5/6/2015 by K

5.8 MAIL MERGE

Mail Merge is generally used when a user wants to send the same letter or document to
different persons with different addresses. It basically helps us to merge the address data base with a
form of letter to create individual letters. Thus it saves times when you want to send the same letter to
large number of people. Steps in mail merge:

e Select Tools on the main menu.

o Select Letters and Mailings -+ Mail Merge.

- Microsoft Word .

iew Insert  Format | Tools | Table ‘Window Help  Foxit Reader FDF

a4 (3 | i & | speling and Grammar... F7 Am Eig = |E|| Gl e -

{44 Normal G| Research... Alk+Click 7 u ||;|§ ==tz )= E
Language: 3
Waord Count,.. S SRR
. e
Speech -
Shared Workspace, .
Letters and Mailings 3 || Mail Merge. .. |
Macro 3 Show Mail Merge Toolbar
Custarmize, ., |=1 Envelopes and Labels...
Options... Letber Wizard. .,

¥
v
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STEP 1: Selecting the document type
Letters: allows to tailor one letter to many individuals.

E-mail messages: allows to personalize a message as you would form letters and send them
via email.

Envelopes: allows to print envelopes with different addresses.
Labels: allows to print labels with different addresses.

Directory: allows to gather varied but related information into a list.

Select document type

What type of document are you
working on?

i Letters

i E-mail messages
i Envelopes

i Labels

7 Direckary

STEP 2: Establishing the Main Document
Use the current document: uses the document currently open.

Start from a template: uses a preset Word template. Once we make this selection, the
Select template link appears. Clicking it takes to the Select Template dialog box, where you
can choose the template you want to use.

Start from existing document: uses a previously saved document. Once we make this
selection, we can choose from a list of recently used files or select another of your files.

Select starting document

How do wou wank ko set up your
letters?

% Use the current document
i Start from a template

it Skart From existing document

Use the current document

Start From the document shown
here and use the Mail Merge wizard
ko add recipient. information.

STEP 3: Selecting the recipients
Use an existing list: uses a previously saved list.
Select from Outlook contacts: uses your Outlook contacts as recipients.

Type a new list: allows to create your own list by typing each recipient.
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Select recipients

® Use an existing list
i Select From Cutlook contacts

O Type a new list

Use an existing list

lUse names and addresses from a
file or a database,

Browse, .

STEP 4: Writing your document

Address block: allows to specify the format of recipient names, whether to insert the
company name and postal address, and the format of the postal address.

Greeting Line: allows to format how the greeting line will appear (e.g., Dear Mr. Randall,)
and choose which format to use for invalid names (e.g., Dear Sir or Madam,).

More items: allows to insert additional database fields.

Write your letter

If wou have not already done so,
write your letter now,

To add recipient information ko
vour letker, click a location in the
document, and then click one of
the itemns below,

F’] Address block. ..

[?'] areeting line. ..

-:: Electronic postage. ..
Ml Postal bar code. ..

Bl Moreitems...

STEP 5: Previewing your documents

At this point, we are almost ready to merge. It is a good idea to preview documents. We can
browse through the documents by clicking the PREVIOUS or NEXT button. We can also
locate specific recipients.
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Preview your letters

One of the merged letters is
previewed here, To preview
another letter, click one of the
following:

Recipient: 1

[# Find a recipient. ..

Make changes

Yo can also change your recipient
lisk;

Edit recipient list. ..

‘ Exclude this recipient

STEP 6: Completing the merge

Advanced Features of Microsoft Word

Once the merge is complete, we can print the merged documents or, prior to printing, we can
edit individual documents.

5.9 Shortcut Keys
Shortcut
Ctrl+A
Ctrl+Shift+A
Ctrl+B
Ctrl+C
Ctrl+Shift+C
Ctrl+D
Ctrl+E
Ctrl+Shift+H
Ctrl+I

Complete the merge

Mail Merge is ready ko produce
wour letters,

To personalize vour letters, click
"Edit Individual Letters." This will
open a new document wikh your
merged letters, To make changes
ko all the letters, switch back to the
original document,

Merge

R Print...
E—ID Edit individual letters, .,

Function

Select all text in a document

Format selected text as all caps

Bold the selected text

Copy the selected text or object
Copy the format of the selected text
Display the Format | Font dialog box
Center the selected paragraph

Apply hidden text formatting to the selected text

Italicize the selected text
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Ctrl+]

Ctrl+K
Ctrl+Shift+K
Ctrl+L
Ctrl+M
Ctrl+Q
Ctrl+R
Ctrl+T
Ctrl+U
Ctrl+Shift+D
Ctrl+Shift+W
Ctrl+V
Ctrl+Shift+V
Ctrl+0

Ctrl+1

Ctrl+2

Ctrl+5
Ctrl+Spacebar

Shortcut

Ctrl+Equal Sign
Ctrl+Shift+Plus

Sign
Ctrl+Shift+Q
Ctrl+Shift+F
Ctrl+Shift+P
Ctrl+Shift+>
Ctrl+Shift+<
Ctrl+]

Ctrl+[
Shift+Enter

Ctrl+Enter

Justify the selected paragraph

Insert a hyperlink within the selected text
Format select text as small caps

Left align the selected paragraph

Indent the selected paragraph from the left
Remove paragraph formatting from selected paragraph
Right align the selected paragraph

Apply a hanging indent to the selected paragraph
Underline the selected text

Double-underline the selected text

Underline the selected words but not spaces
Paste cut/copied text or object

Paste copied format

Add/Remove one line space before the selected paragraph

Apply single-space lines to the selected text
Apply double-space lines to the selected text
Apply 1.5-space lines to the selected text

Remove selected text's manual character formatting

Function
Subscript the selected text

Superscript the selected text

Apply Symbol font to the selected text

Change the selected text's font

Change the selected text's font size

Increase the selected text's font size by one point

Decrease the selected text's font size by one point
Increase the selected text's font size by one point

Decrease the selected text's font size by one point
Insert a line break

Insert a page break
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Ctrl+Shift+Enter

Alt+Ctrl+Minus
Sign

Ctrl+Minus Sign

Ctrl+Hyphen

Ctrl+Shift+Hyphen
Ctrl+Shift+spacebar

Alt+Ctrl+C
Alt+Ctrl+R

Alt+Ctrl+Period

Shortcut
Alt+Ctrl+K
Ctrl+Shift+L
Ctrl+Shift+N
Ctrl+Shift+S
Alt+Ctrl+1
Alt+Ctrl+2

Alt+Ctrl+3
Tab

Shift+Tab
Alt+Home
Alt+End
Alt+Page Up
Alt+Page Down
Up Arrow
Down Arrow
Enter

Ctrl+Tab
Ctrl+N

Ctrl+O

Advanced Features of Microsoft Word
Insert a section break

Insert an em dash

Insert an en dash

Insert an optional hyphen

Insert a nonbreaking hyphen

Insert a nonbreaking space

Insert the copyright symbol

Insert the registered trademark symbol

Insert and ellipsis

Function

Enable AutoFormat

Apply the List style to the selected text
Apply the Normal style to the selected text
Apply a style to the selected text

Apply the Heading 1 style to the selected text
Apply the Heading 2 style to the selected text

Apply the Heading 3 style to the selected text

Move to next cell in a row; Start a new row if pressed within a row's
last cell

Move to previous cell in a row
Move to the first cell in a row
Move to the last cell in a row
Move to the first cell in a column
Move to the last cell in a column
Move to the previous row

Move to the next row

Start a new paragraph within a cell
Insert a tab within a cell

Open a new document that is the same type as the current or most
recently opened document

Display the File | Open dialog box



Basic of Computers
Ctrl+W
Ctrl+S
Alt+Ctrl+S
Alt+Shift+C
F1
Shift+F1
F2
Shift+F2
F3
Shift+F3
F4
Shift+F4
F5
Shift+F5
F6
Shift+F6
F7
Shift+F7
F8
Shift+F8
F9
Shift+F9
F10
Shift+F10
F11
Shift+F11
F12
Shift+F12

Close the current document

Save the current document

Split the document window
Remove the document window split

Display Word Help dialog box

Open Reveal formatting dialog box or open context-sensitive Word Help

Move selected text of object

Copy the selected text

Insert AutoText

Change the case of the selected text

Repeat last action

Repeat Find or Go To

Display the Edit | Go To dialog box

Move to the last change

Move to the next pane or frame

Move to the previous pane or frame
Display Tools | Spelling and Grammar dialog box
Display the Tools | Language | Thesaurus dialog box
Extend the selection

Shrink the selection

Update the selected fields

Switch between a field code and its product
Activate the Word menu bar

Display the shortcut menu

Move to the next field

Move to the previous field

Display the File | Save As dialog box

Save the current document
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Advanced Features of Microsoft Word

SUMMARY OF THE LESSON

You learnt the following in this lesson:
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Data can be exported/ imported in MS-Word.

In MS-Word, pictures can be inserted by various ways such as using AutoShapes, ClipArt,
From Files, from scanner and Camera etc.

Multi-Column facility makes more than one column in single document.
With the help of spell check option, we can make error free document.
To create a table, select Table > Insert > Table

You can enter data in a cell of a table by clicking in it.

To insert rows / columns select, Table > Insert

To merge cells, select Table > Merge Cells

A macro is a series of word commands and instructions that is used as group together as a
single command. Word macros can help save time by automating repetitive tasks. Macro is
used to edit and format the document.

Mail merge is used to send same letter to different recipients.
SELF ASSESSMENT QUESTIONS AND EXERCISES
Discuss the steps of import and export in MS Word.
What is the use of Frame? How a frame can be created?
Discuss Table- handling in MS-Word.
How multi-column document can be created?
What are the steps for recording and running of a macro?
Discuss various ways to insert picture in a document.
How a table can be created?
What are the steps to insert row and column in a table?

How can you format text in a table?

. How will you insert an Autoshape in your document? Explain.

. What is Clip Art gallery?

. Inserting a table in your document saves a lots of time, how? Explain.
. What is the difference between clip art and word art?

. What do you mean by macro?

. What is the purpose of Mail merge?

. How can you create and use a macro?

. Describe the concept of Mail merge by giving suitable example.





